Slave MFD12- System ID unavailable



I had to replace my master MFD12. Since the replacement, my slave MFD12 will not register the new system ID from the new master MFD12. I followed the install instructions exactly. I tried the factory reset trick. I have tried a number of varied restarts and re-installations, but now I am almost out of attempts and ideas. Any help would be appreciated. Thanks guys!
We will try and help. A few questions first.
Has the master been set as the DHCP with the salve set as DHCP off?
When you run the installation wizard does the master see 2 MFDs duruing the countdown?
What else is connected in the system?

Hopefully this gives us a good place to start.
DHCP settings were correct
Setup saw both displays
I have a GP37, Hub101, FA-30 i think and DFF1

I guess the Gremlins got bored and left because all i did was swap the master and slave ports on the hub and try to reinstall a few more times. Guess that was enough to do the trick. Thanks for the quick response Mel.