NN3DBB stopped seeing DRS12


New member
I have a Furuno navnet3 system consisting of NN3DBB,DRS12,AIS-50,BBWX2,DFF1,MaxseaTZ and Nobletec trident. These are all the cat5 networked devices
Getting boat ready for Bahamas cruise next week and decided to check nav system. Radar has x thru it all other systems working including NMEA2K (run on
Its own bus not thru radar antenna). Ran installation wizard several times and it does not see the radar. Have checked cabling and power to radar all good.
Cable is one continuous furuno Siamese cable and it is plugged in to port 3 on main BB green light is blinking but there is no amber light. Tried plugging
cable into router (non furuno) that is connected to BB port 4 and get blinking green and steady amber still does not see radar thru installation wizard.
This system was installed new spring 2012 and the radar was working fine on last trip 3 weeks ago. Any help would be greatly appreciated.

I have experienced that my NN3D (MFD8) some times forget which radar to use..
Somewhere in the menus you can select which radar to use (even if you have only one installed), can't remember exactly where. Check this setting.
The NN3DBB could not find the radar at all. Since my first post I tried disconnecting
the BBWX2 from port 4. Witch effectively disconnected all other network devices except
for two keyboards and radar. The radar then came back to the party.
From time to time my system loses network devices and I wonder if it involves IP conflicts?
Currently I have NN3DBB,FA-50,BBWX2,DRS12 and DDF1 I believe they are all DHCP devices
except for the NN3DBB witch is DHCP server.

Other devices are:
Maxsea TimeZero: fixed ip
Nobleltec Trident: fixed ip

Two Axis PTZ 215 and 4 fixed ip

I there a better way two set these up?
Mabe the Furuno devices can be set to fixed IP?

Thanks in advance,

The NavNet 3D doesn't like it when you add or take things off of the network. If you add MaxSea or other items one time and then don't have them on the next time, it can cause your network to shuffle assigned IP address and you might have to re-select your radar and/or sounder. This normally isn't a big deal. In your case; if you are not seeing the radar when running the wizard then that IS an issue. Being that the problem cleared when you didn't use the Weather unit/hub makes me think that either you have a bad network cable in your system or someone has turned on a power sync setting that shouldn't be on. Power sync should only be on for MFDs, DFFs, and radar supplemental power supplies.