Native Exception error


New member
My MFD8 would not start up today. The Furuno page started up for about 20 seconds then went very dark. The blue bar along the bottom gets about half way then a box pops up saying "Error
A native exception has occurred in Furuno Black Box.MFD. exe. Select quit then restart the program or select details for more information.

I have selected quit a number of times. The screen brightens back up for about 20 seconds, it blinks a couple of times then goes dark again and the process repeats it's self.

If I select more details I get
exception code oxc0000005
exception address 0x018b94a0
reading 0x00000000

I have shut the unit down a number of times. When I do this the usual countdown box does not appear. I have also disconnected and reconnected the power supply and then tried restarting that way but no luck.

I bought the unit on February 28/11. It has approximetly 635 hours on it now.

Can you offer any suggestions on getting things running again. Thanks
I am not a Furuno rep, or have knowledge of the boot process, but I have to ask: have you updated the firmware recently (like to v2.11)? An MFD8 shouldn't be using MFD/BB files (Furuno Black Box.MFD. exe) so I'm wondering if you might have inadvertently updated the firmware with the BB version. If that is at all possible then you might try downloading the MFD8 v2.11 update and reinstalling. In fact, I would probably redownload and reinstall anyway. If that doesn't work I would download and install a completely new copy of the firmware. I have not found that readily available on the Furuno site but one of the Furuno posters should be able to give you a link.

I'm sure I have seen that error and it confused me too as I have an MFD8. It occurs for me after adding/deleting charts.

I have not updated firmware, I am still running what ever it came with, 2.07 I think it is. I went out again today but it still won't work. I'm hoping a Furuno tech will weigh in on a solution.

OK, pretty strange. So does gdfisher have a solution for getting past the error?

If you don't mind losing your settings and waypoints (but not the charts) you might try a Master Reset. To reset first hold down the Cancel button and then power up the MFD, continuing to hold down the Cancel button for 1-2 minutes until the Installation Wizard appears. Power off and it should be reset. Then try powering up.

If you are desperate to not lose your waypoints then you might try installing the v2.11 update and hope that unsticks things in the process. Do read and follow carefully the instructions with the update.

Once the MFD is back to normal, you should update to v2.11. Also back up your waypoints and user settings to the SD card occasionally if you would be bothered by losing them.

my unit has exhibited this behaviour on v2.07 and v2.11. I have always been able to recover from it by turning the unit off and back on. That isn't working for Dave so a master reset may be a good idea. Note that you will also need to re-input any map Unlock Codes if you have any.
Thanks for the replies. I am not a computer whiz so these things stump me and scare me somewhat. I have hesitated from up dating to v2.11 because of the problems I have read about. I don't really understand what I will gain. Everything has worked fine in the past.

If I cannot get the thing up and running without a master reset then how will I be able to save my waypoints? I am assuming all points and routes will be lost if I do the master reset by holding down the cancel button and hitting the power button.

Correct. Have you tried disconnecting everything except power and then turning it on. It's a long shot....
Cycling without any connections except power is worth trying. Also in the Hail Mary camp is the firmware upgrade, but if you value your waypoints then give it a try - firmware upgrades don't wipe the waypoint/route data. As I said earlier, you should upgrade the firmware anyway (and make backups of the data once you have it working).

Firmware upgrades are nothing to be afraid of. You just need an SD card and a card reader for your computer. The connections should be removed so just follow that attempt with the upgrade. Then go to the Furuno product page for the MFD8 ( ... n+Displays), select the "Software" tab and click "Agree" to the license agreement. You will be presented with a list of items; download the last one (combo update 2.11) and unzip it on your computer. Move the resulting folder to the SD card (important: it must be at the top of the folder hierarchy). Then put it in the MFD's upper slot and fire it up. The MFD will do the install, and when finished the cursor will become a plus sign (+). Then power off, remove the SD card, power up and hope it is fixed.

Good luck,

A master reset wipes the waypoints & unfortunately this is needed prior to installing 2.11. Cheers.
Good catch. The instructions call for the reset - it is good practice - but I doubt it would prevent the MFD from booting. To be extra careful, first download and install the combo 2.07 update, which will just overwrite part of the current firmware with the exact same thing; this wouldn't require a master reset. Then if it powers up: backup the data, master reset, install 2.11, and reinstall the waypoints. We are just trying to get the MFD to boot and the waypoints can be recovered; the 2.11 upgrade is just gravy.

All suggested course of actions are valid. The reported error is normally caused by leaving the TIDES and/or CURRENTS overlay turned on for long periods with software 2.07 or older. (For MFD12/MFD8) A incremtental update won't work if the unit isn't coming up. (incremental requires you to go into MENU - under FILES) You will have to clear the unit and conduct a COMBO update.
So I am back up and running. I tried disconnecting all the cables except the power but that did not do it. In the end I had to do a master reboot. I have of coarse lost all my points and settings. My VECTOR charts also messed up. I had these installed by the dealer when I bought the unit. I guess I have to have him reinstall them or something. I down loaded RASTER charts myself last year but they are fine.

I was unaware that just having the tide and current arrows on the chart was considered having them turned on. It has run like that since the day I got it.

At this point I will also update to the 2.11 but I will take the unit to my Furuno dealer because I have learned that I cannot download the file onto my computer because I have a MAC. Is this true?

Thanks for the help everyone.

It is great to hear your progress. :jump
Your vector charts are not changed when you clear a unit. Your Unlock codes are. It would have cleared you codes for any licensed charts. You only need to re-enter your code(s) for any licensed charts, and then select them for use. There is no need to re-download anything at this point. If you do ever need to download charts, it can be done on a MAC. Data is data. You would not be using it on the MAC. You would still need to uncompress the files but there are unzip programs available for the MAC.
We have also had this error a couple of times on v2.07. It was not related to adding/deleting charts - we have added and done nothing since new - it is just random. Turning off and on always works. I don't know about the newest firmware since we have not used it yet.

Unfortunately I have lots of experience with crashing MFDs. First, don't worry about the error message saying it's the Black Box that crashed. All the crash messages I've seen say that.

If I recall correctly, don't you need an operational MFD to go through the FW update process? I don't think yours in getting far enough for an update to even be an option.

Back a couple of years I had exactly the same thing happen to one of my MFDs. It would crash during the boot process, and never get to a point where you could get past that. It was a while ago so my recollection of the details is fuzzy, but as best I can remember here's what I saw:

- I got the exception message during boot just like you, but as I recall I had no cursor or button control, so there was no way to click whatever button it wanted you to click.

- In my case, under instructions from Furuno, I had to connect a keyboard to the USB port on the back of the offending MFD. Because of my installation, this was MUCH easier said than done. Once the keyboard was attached, there was some key sequence that reset things enough to get out of the boot failure loop.

- I'm not certain, but I think what I ended up doing was a master reset which subsequently required re-configuring the MFD.

If you can wait until Monday Furuno may have a less destructive solution than a Master Reset, but if you can't wait, I think the Master Reset is the way to go. I don't know how to do it, but I think someone in an earlier post said how.

I'm sure glad my crash like yours didn't happen while at sea or in an instrument-only navigation situation. I've had other crashes in such unfortunate circumstances, but the system has always rebooted, though it takes several minutes to get your eyes back.

As for upgrading to 2.11 (I'm running 2.07) I see very little reason to do it unless you are experiencing one of the problems specifically fixed in 2.11. And form reading the fix list, 2.11 is much more about new features for certain companion devices and includes almost no fixes for problems like these crashes. The tides/current crash is arguably the one exception, but the "fix" was just to automatically turn off tides and currents after a period of time. To me that's not worth the hassle of saving and restoring all your data, the time to upgrade everything, reenter chart codes, reconfigure the whole system, and risk that something goes wrong along the way. It's a bit of the Microsoft-upgrade-syndrome.... you hope and pray that an upgrade doesn't wreck your system and render it unusable. I just leave tides and current off and use a different program. It's more accurate anyway.