PINK SCREEN on MFD12

PINK SCREEN on MFD12

Postby aquabelle » Mon Jan 08, 2018 1:43 pm

I have had years of trouble-free performance from my NN3D MFD12, which I purchased as soon as they became available. I have immediately updated software whenever an update has been made available and am running the latest version now.

However, during my current long cruise, on two occasions when in chart mode, the MFD12 has suddenly displayed a fully pink screen. On the first occasion, I also had my DRS-4D radar on and in overlay mode and I received a message “radar connection cut” briefly, immediately before the entire screen went pink. It stayed that way for several minutes while I tried to figure out what had happened but I was then able to power off the MFD using its own power button, then re-start and all seemed normal. I continued cruising without problems for another week, then this time, no radar operating, the screen again went fully pink for about 15sec, but this time the MFD re-booted itself and appeared to operate normally for the next 4 hours until I shut down.

I am still away on our 6 week cruise and it has been fine for the 24 hours since this second episode, with radar variously on and off. The MFD had been on for about an hour at the time of the first incident; and for only 20minutes at the time of the 2nd event. In the earlier weeks of my cruise, there were 10 hour days when the NN3D system was fully up and being actively used continuously, without problem.

The MFD is supported by 320B and 330B gps units (the latter on the DRS-4D’s CanBus network and in backup/failsafe mode); a Furuno/Airmar DT-800 transducer provides depth and seawater temps; an ETR6/10 network sounder (not operating at the time of the pink screen incidents); and DSC & AIS inputs are received from Standard Horizon VHFs. The MFD12 is well-protected inside the lower helm of my motor yacht; it outputs to a Furuno MU-15 display at the upper helm (also well protected) via the DVI connector. I have no reason to think power supply was anything other than stable at the time of each incident.

Of course when I get back I could just pull the unit and ship it off to the local Furuno dealer for inspection….but I am guessing I am not the first to experience this pink-screen effect and I am hoping that you might be able to advise the most likely cause(s) of this?

Thanks in advance.
aquabelle
Furuno Super Fan
Furuno Super Fan
 
Posts: 87
Joined: Wed Nov 02, 2011 7:37 pm


Re: PINK SCREEN on MFD12

Postby Johnny Electron » Mon Jan 08, 2018 3:19 pm

Thanks for giving all the details. You did a great job of explaining your system and problem.

I have no idea why you would get a pink screen. Is it breast cancer awareness month? (joke) The only thing that comes to mind is low power or some sort of power spike. Did you notice a generator/refrigerator or something kick on when it happened? You might want to take a photo of the screen next time it happens. Something in the photo might give us a clue. Was the entire screen pink or did you still have your frame and status icons at the top?
Johnny Electron
User avatar
Johnny Electron
Moderator
Moderator
 
Posts: 3291
Joined: Tue Sep 06, 2011 4:26 am
Location: USA

Re: PINK SCREEN on MFD12

Postby aquabelle » Tue Jan 09, 2018 1:05 am

Thanks Johnny....the WHOLE screen went pink. If it happens again I'll certainly try to grab a pic. I don't have any reason to think there was any kind of power spike,,,but if it happens again I'll look at my battery monitoring system read-out (as I'm reaching for the phone to take a pic!!) and see if anything odd is going on. I'm encouraged that this is not something others have reported (I think )

regards
aquabelle
Furuno Super Fan
Furuno Super Fan
 
Posts: 87
Joined: Wed Nov 02, 2011 7:37 pm


Return to NavNet 3D

Who is online

Users browsing this forum: No registered users and 2 guests