Navpilot 700 - no nav data

Not open for further replies.


Furuno Super Fan

Just completed the installation of a new Navpilot 711 and after all installatin check, settings, calibration and sea trial i ought to try to navigate to an "active" route in the MFD12; when choosing NAV it prompted me with an empty SOURCE and empty WPT; if i accept it goes into error claiming : NO NAV DATA. WAIT FOR 1 SECONDS.

I checked that the MFD12 (Navnet3) is defined as the NAV DATA SOURCe in the configuration. I have the PG700 sending heading data and the MFD12 sending the position which are displayed on the NavPilot display.

So what am i doing wrong ? I have checked the complete documentation of the MFD12 and there is no reference to the Navpilot. Is there a PGN that should be output which is not ?

Any help would be appreciated.

Yes if wired via NMEA 2000, you must send over PGN data from the MFD12 to your NavPilot to provide steering instructions.

Please run the Installation Wizard again in your MFD12 and make sure that the following NMEA2000 PGNs(Strings) are enabled to send to the Autopilot:

After you select the above PGNs, Save & Exit, then restart the power on both units and retest it.

Hi Johnny

That did the trick ! I was missing the crosstrack PGN. I was still on the dock so no real trial on the sea but at least while pushing the NAV button with an active waypoint it told me the NAVNET3 as being the source. Altough the waypoint was not named, i believe it is because the boat was not moving and had not crossed a first waypoint.

Did that mean that when i will opened up MaxSea on my laptop, connected to the Furuno Hub, i will be able to define it as another source on the Navpilot 700 ?

I am glad to hear you got the NavData problem resolved. When you have the MaxSea connected and in sync with the NN3D system; then you conduct a GOTO from the PC, it will be just like any other MFD on the network. You will get the point on your NN3D and MSTZ with the active bearing line to the waypoint. You only need to hit NAV on the autopilot and confirm. The waypoint name will not show up on the pilot. It will just provide a generic number of the next WP that it has. MaxSea can drive the pilot through the NN3D system via the Furuno Network or via 0183. If connected by NMEA 2000, then MaxSea can only listen to data but not transmit. (at this point of time anyway) It sounds like you have everything working the way it should. Great Job! :jump
Hi Johny,

I had a sea trial tonight in real conditions. Wow this is the first autopilot in my sailor's life so i'm quite puzled by its capabilities. I would like to ask you, when i select a point on the Navnet and do a GOTO on it, then a NAV on the pilot, why the WPT name doesn't appear on the NAV menu below the source ?

Thanks again for your support, :furuno

When it comes to the waypoint name showing up on the pilot, it would be a "nicety" but it doesn’t, and won’t happen. With all the chart plotters out there, each with their own restrictions on name length and characters it would be difficult to make it work the same, with them all. This includes the differences between the Vx2 and the NN3D when it comes to waypoint name restrictions. It isn’t really a big deal, when you think that the pilot only drives to one point at a time. Once the Navigation starts most people watch the plotter not the pilot. It would be nice if it used the real waypoint name and not its own (next in series) name, but unfortunately that is how it works.
I'm having the same error message on my Nav 700 autopilot running with a Furuno VX2. Help!
Getting back to my "No Nav Data" issue i think i have a good clue of the problem. Yesterday upon activating a route on the Navnet 3D i experienced again the problem. It has been a long time without the problem so i took a lot of notes:

The route is active on the Navnet3D.
The source 1 defined on the Navpilot is the Navnet
The 15 seconds have been waited
When hitting NAV, Source is empty in the panel.
Of couse i do not confirm.
If i shut down the pilot and reopen it; hitting Nav it shows the Source as being the Navnet
but it failed with the No Nav Data.

I tried everything:
Getting through the config of the Navpilot
Cancelling the route on the Navnet 3D and re-enable it or enable a Waypoint and Nav to it
Changing the source to Source 3 which is my RD-33, the Navpilot is always ready to navigate to the RD-33 waypoints...
After 30 minutes of all of this... i tried something i never did; closing the breaker to the Navpilot unit.

Upon restarting the Navpilot ... it worked instantly to NAV with the Navnet 3D.

I am entering the twighlight zone of some memory or messages corruption on the Navpilot control unit when it has been "on" (breaker on but head off) for some days ? Is there any known issue with that ?

Next time i have the No Nav Data i will directly go to the breaker just to see if this was a luck or a real solution to the problem.
It sounds like some of the strange intermittent issues that you see when an installer forgets to put the proper terminator on the back of the control unit. Please verify that all your control units of your pilot have either two cables OR a cable and terminator.
Hello Johnny,

Indeed there is a terminator. But i wonder why the GP-33 is always a valid source, ready to Nav, never add any problem to put into NAV mode on it. An the MFD12 is phantom, not always there ? Both the GP-33 and the MFD-12 are on the same Navnet network so any issue about messages or logical, physical network should affect them both. But never the GP-33 has failed to show up in the Nav mode.

Yesterday i had the issue again, and maybe i have a clue because i had put the GP-33 on anchor watch (the MFD12 is closed at night to save current). Upon doing the morning routine, starting the engine, powering the MFD-12 (all other network instruments are always on the PG-700, the GPS etc), powering the NavPilot and waiting the 15 seconds then Nav and again no data. Changed source to the GP-33 and Nav and it was ready to go, even showing the waypoint.

I tried to depower completely the autopilot like i did before ... but it wasn't of any help. Then i was out of idea.... but i thought to stop the GOTO that was defined in the GP-33 as part of the anchor watch. Upon stopping the navigation on the RD-33 and going back to the NavPilot console, i did a NAV and voila it did work.

This is a new clue to the equation, why would the MFD12 be in such a conflict with the RD-33 as to make the NavPilot unable to recognize it as a valid source (when the problem occurs there is no Navnet field in the confirmation sentence of the Navpilot) which means there is no messages going from the MFD12 to the Navpilot or something is corrupting the message or the way to process it inside the Navpilot.

This is becoming to get tricky... is there any diagnosis mode on the Navpilot that would permit to know a litle bit more about what is happening in the Navpilot when it display an "empty source" ??? Because if that means it has not received a valid sequence of message then we really have a problem with this configuration ?
If the NavNet is on the NMEA 2000 network, it should show up as a source item (regardless of what sentences are on or off). If you are intermittantly seeing the NN3D MFD, I would suspect a NMEA 2000 bus problem. When selecting your NAV DATA source; You don't have it set to "BOTH" do you? It really sounds like a NMEA 2000 bus issue to me. When NMEA 2000 has problems it can be very intermittant.
My source were not set to both, the source1 by default is the Navnet and the source2 is the GP-33. I can switch from one to the other by pressing NAV a few seconds.

The good news is that i can reproduce the problem ! If there is a route defined on the GP-33, then if i want to Nav using Source1 (Navnet) i see the "Navnet in the source field but no data. As soon as i stop the route on the GP-33 then i can use the Navnet as a valid source without the "No Nav data" or without an empty source field.

It is great that i can reproduce the problem but now how to solve it... The GP-33 is working all the time, it is only the Navnet which seems to be more sensible to something.
Do you think of something in the configuration of either the Navnet or the GP-33 that would make the GP-33 shadow or disable the nav command to the Navpilot ?

Do i have enough information to call Furuno service or does this problem would neet an NMEA2000 monitor-sniffer and a qualified person ?

I tested the NavPilot 700 with a NN3D and GP33 with a very large backbone using our test bench. I could not duplicate your findings. I could navigate with either the NN3D or GP33 without problems. I even left both units with navigation points (GOTOs) and switched back and forth without problems. I would go to STBY, switch nav sources (by holding NAV for more than two seconds) then "NAV" to start using the other unit. I didn't even wait 15 seconds between switching. Our Denton Maryland office, General Manager has a center console boat with NN3D MFD8, TZT9, DRS2D, GP320B, GP330B, GP33, BBWX1 Sirius Weather, Hub101 and DFF1; he also had no problem switching. It sounds like either your MFD has some sort of intermittent NMEA problem (unlikely) or your NMEA 2000 bus has something wrong/bad. You could send the MFD into the service center for a full checkout and work it from there. NMEA 2000 bus problems are a bear to troubleshoot and might run up some service time with a dealer. I would recommend you start by having the MFD checked by the service center.
Thanks very much for having taken the time to try to reproduce the problem. At least now i have a reproductible failure that i can work on. So you think it is the MFD we should start diagnosis and not the NavPilot ? When i'll be back i will do a thorough review of the Navnet network. I could also install a simple network using the PG700 the GP33 and the MFD12 to see if i still have the problem before deciding to send the MFD.

:furuno i'm sorry to have spammed this part of the forum with my autopilot problem but it has been enormously valuable to me as part as the diagnostic procedure.

best regards
It would more likely be the MFD12 output or the NMEA2000 network than the pilot. If you want, you could wire NMEA 0183 data from the MFD to the pilot and see if you can drive the pilot that way. If the pilot then switches between the 0183 (MFD) and NMEA 2000 (GP33) then you know the pilot isn't having any problems switching sources. Cutting down the NMEA 2000 network to the basics for testing as you suggested is also a good idea.
I'm starting to doubt that the MFD12 has an issue. Last time i was on the water with the boat, the MFD12 refused to accept register a new waypoint. Trying to create a route and nothing happened. Nothing else than the MFD12 was involved, it has been freshly restarted and it refused to enter any new waypoint. It was impossible also to GOTO any previously registered waypoint.

It was possible to navigate to a route though but the NavPilot didn't received anythin so "No nav data" was the result.

This might be the proof that the unit has an intermittent problem. What is the procedure for sending a unit and what is involved as part of the diagnosis of the MFD12 if this is an intermittent and volatile problem like the one i experiment ?

Not open for further replies.