SC-110, SC50 or SC60

SC-110, SC50 or SC60

Postby duffy » Sat Apr 16, 2016 12:11 am

We are using all of these products on our boats. We have a number of spare displays and I would like to add a second display to the SC-110 (or others). I am more concerned at being able to show compass data output from the SC than with controlling the unit.

Is there anyway I can connect a display either to a data port to get data display (I realize that these ports are TX only) or connect using for example the beacon RX/TX port ? Of course I would also need 15v from the display port - if there is enough power for 2 displays.

Alternatively would it cause a problem if I connected 2 displays in parallel but cut the 2nd display unit's TX line on pin 3

Richard
duffy
Member
Member
 
Posts: 18
Joined: Mon Jan 28, 2013 7:39 am


Re: SC-110, SC50 or SC60

Postby X-band » Tue Apr 19, 2016 7:09 am

Hello Richard,

It is not possible to connect more than one display unit to the SC50 SC110 or SC60. The displays required bi-directional communication and will alarm constantly with out it.

I would recommend using a RD33 as a remote display, it will not have control of system, but it will display the heading and GPS data.
User avatar
X-band
Moderator
Moderator
 
Posts: 38
Joined: Wed Jan 16, 2013 10:34 am
Location: Camas, WA

Re: SC-110, SC50 or SC60

Postby ekrone » Sat Jul 01, 2017 3:38 pm

How do I have to configure the output channel where my RD-33 is conected to the Furuno SC-50?
ekrone
Member
Member
 
Posts: 1
Joined: Sat Jul 01, 2017 3:32 pm

Re: SC-110, SC50 or SC60

Postby Melville » Wed Jul 05, 2017 4:10 am

The RD33 requires an optional cable to accept 0183 or you need an optional 0183 to N2K converter since the SC50 is 0183, not N2K.
Melville
Furuno USA
User avatar
Melville
Moderator
Moderator
 
Posts: 849
Joined: Fri Sep 02, 2011 12:33 pm

Re: SC-110, SC50 or SC60

Postby duffy » Sat Oct 21, 2017 4:36 am

Thanks for your help thru this forum.
I have another problem which I cannot solve! An SC60 which seems to be working OK, is stuck on the date of 6 March 1998!
I checked the satellites and it shows 3D with all satellites strength 9 or over.
This wrong date is shown on the SC602 display unit, and output to the Navnet VX2 units to which it is connected from the Nav Out 1 port (to Navnet data port 2 at 4800 baud). The clock time and GPS position data is correct The heading is also correct but that is connected from an AD-10 port.

I have tried closing down and restarting, without success

Could it be a battery problem? The battery in the SC60 was changed about 6 months ago, but not the battery in the SC602 control unit.

All was working well until a few weeks ago - not exactly sure when it went wrong - only noticed when I tried to access tidal info pages. Since the the time and position data heading is correct, I would probably not have noticed the date!
duffy
Member
Member
 
Posts: 18
Joined: Mon Jan 28, 2013 7:39 am

Re: SC-110, SC50 or SC60

Postby mvtime2 » Tue Nov 28, 2017 5:22 am

Same problem - following
mvtime2
Member
Member
 
Posts: 3
Joined: Tue Nov 28, 2017 5:18 am


Return to Instruments

Who is online

Users browsing this forum: No registered users and 1 guest